[BUG - FIXED] game 839

[BUG - FIXED] game 839

Message par Torfi Torfnase » 20 Avr 2014 23:56

in move 51 the violet crystal should not be dropped onn the teleporter but stay to the green robot.
in move 52 the green robot should have picked up the green crystal and not the violet one lying on the teleporter.
Torfi Torfnase
 
Message(s) : 11
Inscription : 14 Oct 2012 16:07
Localisation : Berlin

Re: bugs in game 839

Message par Torfi Torfnase » 21 Avr 2014 0:01

move 53 the big again.

Is there a chance to repair the match?
Torfi Torfnase
 
Message(s) : 11
Inscription : 14 Oct 2012 16:07
Localisation : Berlin

Re: bugs in game 839

Message par Dermerlin » 21 Avr 2014 2:15

Torfi Torfnase a écrit :in move 51 the violet crystal should not be dropped onn the teleporter but stay to the green robot.
in move 52 the green robot should have picked up the green crystal and not the violet one lying on the teleporter.


I am not sure, but it looks to me like a display bug and no game bug.
in my eyes:
- in move 51 the crystal stayed on the green robot and didn't drop on the teleporter. The crystal was just displayed there, but stayed on the robot.
So...
- in move 52 the robot couldn't pick up the green crystal as there was already one lying on it (namely the pink one, which was wrongly displayed on the teleporter). So the pink crystal wasn't picked up, it was just displayed correct in the next turn.

Just guesses, but i am pretty sure that's what happened.
Dernière édition par Dermerlin le 21 Avr 2014 14:52, édité 1 fois.
Avatar de l’utilisateur
Dermerlin
 
Message(s) : 510
Inscription : 07 Juil 2011 1:07
Localisation : Dortmund, GERMANY

Re: bugs in game 839

Message par Dermerlin » 21 Avr 2014 2:16

Torfi Torfnase a écrit :move 53 the big again.

Is there a chance to repair the match?


And if i was right in the former post, this will probably be a display bug again?
Avatar de l’utilisateur
Dermerlin
 
Message(s) : 510
Inscription : 07 Juil 2011 1:07
Localisation : Dortmund, GERMANY

Re: bugs in game 839

Message par diplojak » 21 Avr 2014 10:23

Dermerlin is right, it's twice a display bug, the crystal should have followed the bot through the teleporter and not stop on it... Even if the animation is wrong, at the end you should have seen the right situation... except I removed the final display since Chrome broke everything with its last release.
I will fix the bug... I can change the game in friendly game if you will...
Avatar de l’utilisateur
diplojak
Administrateur
 
Message(s) : 7215
Inscription : 28 Jan 2004 13:38
Localisation : Lille - FRANCE

Re: bugs in game 839

Message par diplojak » 21 Avr 2014 10:37

bug fixed (but I can't repair the display, sorry)
Avatar de l’utilisateur
diplojak
Administrateur
 
Message(s) : 7215
Inscription : 28 Jan 2004 13:38
Localisation : Lille - FRANCE

Re: bugs in game 839

Message par Torfi Torfnase » 21 Avr 2014 11:12

thanks, now that we know what happened we can handle the display bug.
Torfi Torfnase
 
Message(s) : 11
Inscription : 14 Oct 2012 16:07
Localisation : Berlin


Retour vers Twin Tin Bots

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)

cron